This project has moved and is read-only. For the latest updates, please go here.

Error "Could not read file"

Apr 20, 2009 at 2:02 PM
I get an error when I try to run clone detective.
When I look in the log file I find this:
* WARN  : Could not read file: File 'E:\Projects\Incordia.Framework\Dev\Solutions' not found[E:\Projects\Incordia.Framework\Dev\Solutions (Access is denied)] (DefaultCloneDetection.cqa.clonedetection.detection.detection-unfiltered)
* ERROR : Processor 'DefaultCloneDetection.cqa.clonedetection.detection.detection-unfiltered' failed gracefully: Empty input encountered! Clone detection aborted. (DefaultCloneDetection.cqa.clonedetection.detection.detection-unfiltered)
Before these lines it's only INFO messages, after them there's a lot of WARN messages.

E:\Projects\Incordia.Framework\Dev\Solutions is a folder that "Everyone" has full control of.

I've got this structure:

When I tried to move Incordia.Framework.sln to the root it all worked well. Maybe some bug that makes gets the path to the solution mixed up..?
I can't don't want to change the structure of the solution. So I need this fixed.

Is there any way to make it work? Can I in some way try to fix it myself? How do I debug it?