This project has moved. For the latest updates, please go here.
2
Vote

Clone detection failed, no good error message

description

Clone detection failed, se log.

Lastest .Net, lastest java.

Perhaps a better errormessage could help?

file attachments

comments

dallmair wrote Jan 8, 2010 at 6:09 AM

Buurd,

you're totally right, we should add a special handling for the very common "empty input encountered" case. For reference and traceability, here are the relevant lines from your log:
  • WARN : Could not read file: File '\litium.local\files\Users.Jonkoping\010rolhei\My Documents\Visual Studio 2008\Projects\arbio' not found[\litium.local\files\Users.Jonkoping\010rolhei\My Documents\Visual Studio 2008\Projects\arbio (Access is denied)] (DefaultCloneDetection.cqa.clonedetection.detection.detection-unfiltered)
  • ERROR : Processor 'DefaultCloneDetection.cqa.clonedetection.detection.detection-unfiltered' failed gracefully: Empty input encountered! Clone detection aborted. (DefaultCloneDetection.cqa.clonedetection.detection.detection-unfiltered)
As you can see, clone detection failed because of an "Access denied" error on your source files.

d3j409 wrote Apr 13, 2010 at 4:26 PM

I am having the same problem. I get an "Access denied" error on your source files. However, Visual Studio 2008 has no problem accessing these files and I get the error running as both a simple user and as an administrator. Can you offer any additional guidance on how to determine the source of my problems?

dallmair wrote Apr 15, 2010 at 11:34 AM

Hi d3j409, are your source files located on a file share (UNC path)? Regards, Thomas